[Blog] Eigenbau NAS!

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • [Blog] Eigenbau NAS!

      Nabend.
      Vorab, der Clou an dieser NAS ist, dass es nicht aus herkömmlicher Hardware entsteht, sondern aus einem kleinen PC (HP Elite Slice), der dafür absolut nicht ausgelegt ist.
      Die ganze Dokumentation ist relativ lang und wohl nur was für Hardcore interessierte. In meinem Bekanntenkreis kam die Zusammenstellung gut an, und teile meine Erfahrungen nun auch hier, vielleicht bekomme ich auch Feedback oder nützliche Tipps :)

      PDF: pewx.de/sharex/NAS.pdf
      OneDrive (PDF): 1drv.ms/b/s!AlWYje_kIjPygYI-DeV0ZK2K8R12ag

      Ich habe versucht alles hier in dem Thread zu schreiben (pewx.de/sharex/2018-03-12_HZNevc-723.png), aber das ist meiner Meinung nach komplett unübersichtlich. Die PDF ist schön strukturiert. Sobald es was neues gibt, lass ich es euch hier wissen. Alle neue Einträge schreibe ich als Post hier.

      Freue mich auf Feedback,
      gute Nacht :)
    • Heyho.
      Gibt viel zu erzählen (nur 4 Seiten mit viele Bilder :P), denn der China Adapter ist endlich da!
      Die Links oben im Beitrag zur PDF sind entsprechend aktualisiert, ich packe sie aber hier noch mal rein.

      PDF: pewx.de/sharex/NAS.pdf
      OneDrive (PDF): 1drv.ms/b/s!AlWYje_kIjPygYI-DeV0ZK2K8R12ag

      - -

      Hier die erste Seite von heute als "kleine" Lesevorschau^^
      28_03_2018 Der China Adapter

      In der Zwischenzeit hat sich einiges getan und es gibt heute viele Bilder. Zum einen kam der M.2 auf PCIe Adapter aus China, Startschwierigkeiten mit dem Netzteil und eine komplizierte Verkabelung stehen heute auf dem Programm.
      Wie im letzten „Abschnitt“ beschrieben, wollte ich das Modul in Verbindung mit dem Netzteil testen. Im ersten Anlauf hat das mal gar nicht geklappt. Einfach gesagt, dass Netzteil startet, wenn man PS_ON (grüne Leitung) auf Low Pegel zieht, also mit Masse (schwarze Leitung) kurzschließt. Und genau das habe ich erst mal manuell überprüft mit dem Ergebnis: startet nicht. Meh!
      Der Grund dafür war aber sofort klar, dass Netzteil benötigt eine Mindestlast um zu starten was bei den Schaltreglern eigentlich auch Sinn macht. Wer sich dafür interessiert kann ja danach googlen
      Mit der Hoffnung das die Festplatten Mindestlast genug sind, habe ich es nochmal probiert. Und siehe da, Netzteil geht an und funktioniert. YES. Modul dran und alles provisorisch verkabelt, Elite Slice gestartet, das schöne leise „klicken“ vom Relais gehört und siehe da, Netzteil ist an.

      Elite Slice neugestartet -> Netzteil bleibt an
      Elite Slice heruntergefahren -> Netzteil geht aus

      Das Netzteil geht zeitgleich mit dem Elite Slice aus. Gerne hätte ich das es noch ein wenig länger an bleibt, damit ich mir sicher sein kann das die Festplatten in „Parkposition“ sind. Eventuell lässt sich das mit ein paar Kondensatoren realisieren.
      Was ich bisher noch nicht wusste, bei einem Wegfall der Versorgungsspannung wird der Antrieb als Generator geschaltet und mit der gewonnen Energie ein Schwenkimpuls für den Kopfarm erzeugt.

      Aber genug dazu, ab zum Adapter! Auch wenn theoretisch alles funktionieren sollte, es gäbe einige Gründe die dagegensprechen. Schnell alles eingebaut um endlich Gewissheit zu bekommen.
      Beim booten habe ich dann erstmal etwas Angst bekommen. Als ich den SATA Controller an meinem Computer angeschlossen hatte, war noch vor dem booten von Windows die Initialisierung des Controllers zu sehen, was zum Beispiel fürs Hardware RAID wichtig wäre. Dies sah ich hier jetzt nicht. In der Hoffnung das es eine BIOS Einstellung ist habe ich Windows starten lassen und öffnete die Datenträgerverwaltung. Die 500GB Testfestplatte wurde angezeigt und auch die alte 2TB SSHD die ich während der Laufzeit angeschlossen habe wurde direkt vom System erkannt. HotPlug fähig, cool!
      Ein kurzer Festplattentest mit CrystalDiskMark zeigte perfekte Werte bei der SSHD. Leider habe ich kein Screenshot gemacht. Werde ich wann anders nachreichen.
      Nun da ja alles funktioniert, stellt sich jetzt die Frage wie ich alles ordentlich zusammenbaue. Auf dem HP Elite Slice ist noch Garantie weshalb ich keine Aussparung in das Gehäuse machen möchte.

      Deshalb ist klar, ich muss das Flex Kabel vom Adapter an einer Stelle ablöten, durch eine Öffnung vom Elite Slice und dann wieder anlöten. Das sagt sich alles ziemlich einfach…
      Aber ich habe als das Kabel von M.2 Stecker getrennt. Zuvor natürlich ein paar Bilder gemacht damit ich später alles wieder richtig anlöten kann.

      ... weiter gehts in der PDF :P