Fehler bei Rise

  • Hallo Community,
    ich habe seit 5 Minuten den Fehler das ich bei Rise nichtmehr auf den kleinen Login-Button klicken kann. Im debugscript bekomm ich nichts da es bei mir vollgespammt ist.
    Dafür habe ich aber in den Logs was gefunden;"[21:30:32] ERROR: capital/register_login/register_login_server.lua:616: attempt to index global 'adminsIngame' (a nil value)"

    Dann habe ich hier mal die Funktion;

    Lua: register_login_server.lua
    local admnlvl = tonumber ( dsatz["Adminlevel"] )
    vioSetElementData ( player, "adminlvl", admnlvl )
    if admnlvl >= 1 then
    adminsIngame[player] = admnlvl
    end
    if admnlvl == 1 then
    donatorMute[player] = {}
    end


    Tut mir leid das ich nicht die ganze Funktion einbinden könnte, aber dann wäre das Thema zu groß gewesen.
    Naja, ich hoffe einer von euch kann mir helfen!


    Mit freundlichen Grüßen;
    GreenPepper

  • Deine fraktionen -> allround.lua hat einen Fehler und kann nicht gestartet werden.

  • Mit ein bissle rumfuchteln habe ich es nun geschafft, mein Problem ist nur das ich dafür mein /smode Script rausmachen musste.
    Das ist für mich bzw. den Server und das Team sehr unpassend, da wenn mann Supporten muss ja villeicht auch kein Damage bekommen sollte.
    Ich würde keine andre Lösung wissen, es zu schaffen, das ich das "smode" Script wieder reinmachen kann.
    Villeicht hat ja einer ne Idee. Danke im vorraus.

  • Die Funktion hatte einen Bug, weswegen die Datei nicht geladen wurde.
    Fix den Fehler und es klappt.

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!