[Blog] Aufbau: Der Server in der Schublade

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • [Blog] Aufbau: Der Server in der Schublade

      Moin zusammen,
      in diesem Thread handelt es sich um einen kleinen „Blog“, wessen Idee von Doneasty stammt, über den Aufbau des „Schubladen Servers“. Klingt Blöd? Ja, ist es auch!

      Ich weiß das es dafür extra spezialisierte Foren gibt. Es hat aber auch einen bestimmten Grund, warum ich das nicht dort sondern hier verfasse. Zum einen möchte ich mich nicht extra deswegen in einem anderen Forum registrieren, wo mich niemand kennt und zum anderen, war es gar nicht geplant, einen kleinen Blog darüber zu schreiben, denn wie oben geschrieben, die Idee kam von Doneasty :D Abgesehen davon ist der wohl wichtigste Grund für mich, dass ich das ganze nicht professionell aufbaue, sondern nur mit Dingen, die ich zu Hause habe. Es soll also möglichst ohne neue Bauteile zu kaufen aufgebaut werden.

      Nun gut, genug dazu, was hab ich denn Überhaupt vor, und warum das ganze? Ziel für mich ist es, einen kleinen HomeServer zu haben, den ich für lokale Zwecke nutze. Natürlich gibt es da viele Alternativen wie z.B. ein Raspberry, NAS oder auch die FritzBox, die solche Funktionen bietet. Das kam mir aber nicht in Frage, da ich gerne einen vollwertigen Windows Server 2012 aufsetzen möchte. Windows Server Hater verlassen den Thread wohl möglich nun, aber das ist mir wumpe :) Immerhin geht es hier hauptsächlich um den Aufbau. Und um die Frage zu klären, warum keine VM? Bin ich nicht so ganz der Freund davon. Zum testen von einem Betriebsystem ist das ja schön und gut, aber meiner Meinung nicht für eine Entwicklungsumgebung.

      Also, muss ein Server her, doch wohin mit dem Shit? Ungern möchte ich einfach irgendwo einen Tower hinstellen und den laufen lassen. Nebenbei ist das ja auch irgendwie unspektakulär :D Irgendwann kam mir die Idee, wenn ich den Kram aus der untersten Schublade meines Schreibtisches, mal sortieren würde, hätte ich eine freie Schublade, evt. passt ja mein altes Mainboard hinein :)
      Gesagt getan, und siehe da, es passt! Ha, platz gefunden!

      Kein Aufbau geschieht ohne Projektname. Somit entstand ganz simple der Name Schubladen Server. Die Erklärung kann ich mir wohl sparen.

      Kurze Infos noch am Rande, geplant habe ich das ganze schon länger, wie man am Datum sehen kann. Nun soll es aber ohne längere Pausen fertig werden. Falls wer an Stromkosten denkt, der Server soll nicht 24/7 laufen, nur dann wenn ich ihn brauche.

      Planungen (03.11.2014)
      Spoiler anzeigen

      Das Projekt soll nun nicht nach Pi*Daumen aufgebaut werden. Naja, nicht ganz. Deshalb zuerst mal ein Überblick, was ich alles für Komponenten habe, die ich nutzen könnte.

      Mainboard: ASUS M4A785TD-V Evo
      CPU: AMD Athlon II X4 630 4x2.8GHz AM3
      Grafikkarten: Onboard; NVidia 7800GTX
      RAM: 4x2GB DDR3
      Speicher: HDD Western Digital 500GB
      Netzteil: Altes 350W Netzteil (Marke Unbekannt)
      CPU Kühlung: Boxed CPU Kühler
      Sonstige Kühlung: Netzteil Lüfter; 2x 80mm Lüfter

      Und ein altes Gehäuse steht zum Ausschlachten bereit
      Nun gut, da ist doch brauchbares dabei. Nicht das beste, aber es reicht. Folgt eine Maßstabsgetreue „Zeichnung“ der Schublade, Mainboard und der HDD.

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Mainboard.png]
      [Blockierte Grafik: http://pewx.de/res/pictures/server/HDD.png]
      [Blockierte Grafik: http://pewx.de/res/pictures/server/Schublade.png]

      Dies habe ich mit SketchUp erledigt, da es schnell unf einfach von der Hand ging. Wie gesagt, die Planungen müssen dafür nicht perfekt sein, wahrscheinlich halte ich mich da später so oder so nicht dran :D


      Testaufbau und Installation (06.12.2014)
      Spoiler anzeigen

      Wenn das ganze später in der Schublade ist, soll das Ding laufen. Zugriff werde ich über das RDP haben. Dazu muss bevor der Einbau stattfindet, Windows bereits installiert und eingerichtet sein. Also wird das ganze frei aufgebaut.

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Testaufbau.jpg]

      Folgt nun die Windows Server Installation und Konfiguration für das RDP.


      Hardware Änderung (20.04.2015)
      Spoiler anzeigen

      Für meinen PC habe ich mir ein neues Mainboard sowie eine neue CPU gekauft. Somit wird die ausgebaute Hardware nun für den Server genutzt. Vorteil, definitiv schneller und vor allem ist das Mainboard etwas kleiner, was heißt, dass ich mir wohl Arbeit mit Aussparungen an der Schublade spare :) Allerdings muss jetzt eine neue Installation/Konfiguration durchgeführt werden.

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Vergleich.jpg]

      Neue Komponenten:
      Mainboard: ASRock 970 Extreme3
      CPU: AMD FX-8120 8x3.1GHz AM3+

      Eine neue Zeichnung in SketchUp werde ich für das Mainboard jedoch nicht machen. Lediglich wohl die Länge anpassen.


      Bau der Bodenplatte (30.05.2015)
      Spoiler anzeigen

      Der Aufbau soll nicht direkt auf der Schublade stattfinden. Somit dient eine Sperrholzplatte als Bodenplatte. Da die etwas verzogen war, habe ich zwei Holz(dinger) angeleimt, was auch für eine bessere Stabilität sorgt.

      Zuerst mochte ich das Mainboard direkt auf diese Platte befestigen. In einem alten Gehäuse viel mir jedoch die Rückwand auf, welche bereits die perfekten Bohrungen für diverse Mainboard typen hat. Also habe ich diese ausgebaut und schon mal grob zugeschnitten.

      Die HDD soll seitlich hochkant neben dem Mainboard seinen Platz finden. Dazu nahm ich eine Schiene der Sharkoon HDD Vibe Fixer III, die ich ebenfalls in dem alten Gehäuse noch eingebaut fand. Die Schiene lies sich perfekt an der Bodenplatte montieren, und ein Wechsel der HDD ist jetzt auch schnell geschehen :)

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Bodenplatte.jpg]

      Wow, trotz unschöner Ausschnitt, sieht ja fast so aus wie geplant :D


      Stand der Dinge (31.05.2015)
      Spoiler anzeigen

      Da das System mit dem neuen Mainboard/CPU noch nicht installiert wurde, mochte ich das nun machen. Jedoch viel mir auf, dass das alte Netzteil keinen 8 Pin CPU Anschluss hat. Somit muss also doch was gekauft werden. Nun gut, das Problem soll ein Adapter lösen, den ich für 3€ bei Amazon bestellt habe. Mittlerweile denke ich aber, dass das alte „NoName“ Netzteil seinen Dienst getan hat. Immerhin habe ich das schon mehrmals repariert. Also habe ich mir auch noch ein BeQuiet Netzteil mit 300W bei Ebay ersteigert. Den Adapter benötige ich für dieses auch.

      Gesamtkosten: 25€


      Stand der Dinge #2 (02.06.2015)
      Spoiler anzeigen

      Mittlerweile ist das Netzteil angekommen. Deutlich sichtbar sind Gebrauchsspuren. Da es mir aber um das innere geht (immerhin wird es ja ausgebaut), interessiert mich das wenig. Ein kurzer Funktionstest ist erledigt. Nun folgt eine schnelle Zeichnung in SketchUp, um auch mal das Netzteil einzuplanen, weil das bisher nicht geschehen ist.

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Netzteil.jpg]
      [Blockierte Grafik: http://pewx.de/res/pictures/server/NetzteilOffen.jpg]

      Im Übrigen muss ich hier mal die eigentlich bekannte Qualität von BeQuiet loben. Bei dem Blick unter die Platine kamen ordentliche, schöne Lötstellen zum Vorschein, nicht wie bei dem alten 350Watt Netzteil.


      Fertiger Plan, neue Bodenplatte & ordentliche Kühlung? (05.06.2015)
      Spoiler anzeigen

      Der "Bauplan" ist nun fertig. Auch wenn keine Verkabelung im Plan vorhanden ist, sind nun alle wichtigen Komponenten vorhanden. Anschalter/Reset und Status LED's folgen später.
      So schaut das ganze nun aus, relativ hübsch wie ich finde :P
      [Blockierte Grafik: http://pewx.de/res/pictures/server/Aufbau1.png]

      Besonders viel Platz ist da nicht mehr. Allgemein zählt hier jeder Millimeter, und da mich das mit der Bodenplatte ein wenig Ärgert (verzogen etc.), sägt mir ein Kollege zwei (falls etwas schief geht^^) Pappelsperrholzplatten (Stärke 8mm) zurecht. Und das ganze komplett umsonst O: Die aktuelle Grundplatte ist 15mm hoch. Somit habe ich 7mm mehr Luft, was wirklich viel ausmacht.

      Apropos Luft, dies sind nun nicht die zwei 80mm Lüfter, die ich zuerst dafür einplanen mochte. Das sind zwei 120mm Lüfter mit einer Breite von 12mm (i.d.R. sind Gehäuselüfter 25mm Breit), die ich von einem Kollege sehr günstig abkaufen könnte. Damit schweife ich zwar ein wenig von dem Plan ab, blos kein Geld investieren, doch mit der Temperatur in dem Ding möchte ich nicht scherzen.

      Dennoch bin ich mir bezüglich der Kühlung immer noch nicht ganz sicher. Nach der Theorie eines Kollegen, würde er das so, wie es jetzt im Plan ist, für am besten halten. Da die Kühle Luft von hinten nach vorne zur Front gepustet wird. Die Warme Luft könnte zwischen Spalten entweichen. Meine erste Idee war es jedoch, ein Lüfter hinein und der andere raus.
      Letztendlich werde ich es nur am Schluss durch permanente Überwachung und testen herausfinden.


      Voll in Gange (12.06.2015)
      Spoiler anzeigen

      Um das Netzteil ordentlich und sicher zu befestigen, habe ich das Gehäuse des Netzteils zurecht geschnitten. Dort sind direkt 4 Abstandbolzen und eine Schraubverbindung zur Erdung vorhanden. So ist das Gehäuse noch für was gut und erspart mir ein bisschen Arbeit :D

      Nach dem ich nun auch alles auf der neuen Grundplatte befestigt habe (inklusive Netzteil Halterung), folgte ein kleiner Testaufbau. Wobei in dem folgenden Foto die HDD Schiene noch nicht befestigt war. Und wie gesagt, es ist ein Testaufbau, d.h. die Verkabelung ist alles andere als ordentlich.

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Testaufbau2.jpg]

      Nun wäre es doch Zeit, das System endlich mal auszuprobieren! Ätsch!! Ich Idiot habe natürlich den Netzstecker sowie -schalter vorbereitet, um diese in der Schublade einzubauen, was ich aber bislang noch nicht machen wollte, bevor ich die Aussparungen für die Lüfter noch nicht gemacht habe. Natoll; muss ich wohl etwas tricksen, oder noch ein wenig warten.

      Um eine schöne Verkabelung zur garantieren, war es nötig, ein paar Leitungen vom Netzteil ausgehend zu trennen, und neu zu ordnen. Nicht benötigte Stecker wurden so abgetrennt, dass ich die im "Notfall" nochmals zusammen bekomme.

      An der Schublade habe ich nun die Löcher für den Netzstecker sowie -Schalter gebohrt und angepasst. Sitzt soweit alles super und läuft alles nach "Plan" :)

      [Blockierte Grafik: http://pewx.de/res/pictures/server/Netzstecker.jpg]
      Das nenne ich im übrigen Gartenarbeit ;)

      Auf dem Foto ist nicht gut zu erkennen, dass die Leitungen vom Netzstecker noch nicht am Schalter angelötet sind. Dies ist beabsichtigt, damit ich beides noch rausbekomme, um die Aussparungen für die Lüfter zu machen, die ich morgen vom Kollege bekomme. Sobald die Aussparungen getan sind, werden die Kontakte vom Netzstecker und -Schalter mit Epoxidharz eingegossen. Ist mir einfach sicherer, als nur Schrumpfschlauch.


      Montage der Lüfter & R.I.P. Mainboard (23.06.2015)
      Spoiler anzeigen

      Lüfter sind montiert und Aussparungen gemacht. Ich hab ehrlich gesagt damit gerechnet, dass die Aussparungen schlimmer aussehen. Finde es sieht ganz gut aus. Reicht ja auch, Hauptsache die Luft kommt durch :P
      Heute mal ein paar mehr Bilder^^.
      DSC_0618.JPGDSC_0623.JPGDSC_0627.JPG

      Netzstecker und Schalter vergossen. Nicht besonders schön, aber isolierend.
      DSC_0629.JPG

      Bereit für den Zusammenbau (linke Bild leider etwas fehlerhaft fokussiert)
      DSC_0645_komprimiert.JPGDSC_0646_komprimiert.JPG

      Lüfter und Power Taster (Orange/Weißes Kabel) sind jedoch nur provisorisch verlegt, der Rest sollte so in etwa bleiben.

      Nun, einem Test stand natürlich nichts mehr im Wege. Also Netzstecker rein, Schalter ein und mal schauen ob es qualmt. Kein Zuff, kein nichts, alles supi :P Also mal anschalten. Und läuft! Naja, viel zu sehen ist nicht, da weder onboard noch ext. Graka vorhanden war, aber der BIOS beeper hats mir dann verraten. Zumindest fast. Er piepste 5x lang. Wobei, das fand ich auch erst heraus, nachdem ich beabsichtigt ein Fehler gemacht habe, um zu erkennen, was als lang und als kurzer Beep zu definieren ist.
      Das Problem war mir bei dem Mainboard bekannt, und hatte ich auch schon öfters, als es in meinem PC noch eingebaut war. Jedoch kam es nur teilweise, und hab nie danach geschaut. Nun schien jedoch gar nichts zu gehen. Nach den Beep Codes her ist die CPU defekt. Allerdings konnte ich das testen mit der alten CPU, die jedoch ebenfalls nicht lief mit dem gleichen Resultat. Und das ich gleich CPUs geschrottet hab, konnte ich mir nicht vorstellen. Also die CPU am PC meines Vaters getestet, und die lief! Also ist das Mainboard defekt, was auch immer.
      Da ich das ganze nun jetzt nicht in den Sand setzen möchte, soll ein "neues" Mainboard her. Bei Ebay hab ich nun ein gebrauchtes ersteigert.

      Schade drum :(

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von PewX ()

    • Vorweg, heute Abend poste ich, wie es aktuell mit Lüfter und der Verkabelung ausschaut. Gibt ja (scheinbar) wirklich welche, die das interessiert :D

      Corby schrieb:

      Hast du keine Angst dass das Holz durch den Strom Feuer fängt und dein Haus abbrennt? D:
      Durch Strom feuer fangen? Ich habe alles ordentlich verkabelt und an eventuellen kritischen Stellen mit Epoxidharz eingegossen. Da mache ich mir keine sorgen. Und wenn... ist es ja gar nicht mein Haus :P

      Von der Temperatur her, könnte ich mir das ebenfalls nicht vorstellen, da das System ab etwa 70°C abschalten soll.

      Xseam schrieb:

      Das ganze wirkt sehr professionell, machst du irgendwas in die Richtung beruflich?
      Danke, ich finde aber nicht mal das das sooo professionell ist. :D Wie Corbys zuverlässige Quelle bereits rausgefunden hat, mache ich eine Ausbildung zum Elektroniker für Geräte und Systeme (3. Lehrjahr).

      Corby schrieb:

      Gott, ist das angenehm wieder BBCodes zu benutzen
      Da schließe ich mich an, außerdem die super Zitierfunktion :D WBB3 ist in einigen stellen besser als IPB4 :DD
    • PewX schrieb:

      Corby schrieb:

      Hast du keine Angst dass das Holz durch den Strom Feuer fängt und dein Haus abbrennt? D:
      Durch Strom feuer fangen? Ich habe alles ordentlich verkabelt und an eventuellen kritischen Stellen mit Epoxidharz eingegossen. Da mache ich mir keine sorgen. Und wenn... ist es ja gar nicht mein Haus :P

      Ich mache keine Witze mehr.

      ~>The|One schrieb:

      War ja klar das sowas wieder kommt. 'krass und fies' sagt ja alles.
    • Corby schrieb:

      Ich mache keine Witze mehr.


      Du ich kann bei deinen Beiträgen mittlerweile nicht mehr unterscheiden, ob es ernst gemeint oder doch nur Spaß sein soll :D

      - - -

      Montage der Lüfter & R.I.P. Mainboard (23.06.2015)
      Lüfter sind montiert und Aussparungen gemacht. Ich hab ehrlich gesagt damit gerechnet, dass die Aussparungen schlimmer aussehen. Finde es sieht ganz gut aus. Reicht ja auch, Hauptsache die Luft kommt durch :P
      Heute mal ein paar mehr Bilder^^.
      DSC_0618.JPG
      DSC_0623.JPG
      DSC_0627.JPG

      Netzstecker und Schalter vergossen. Nicht besonders schön, aber isolierend.
      DSC_0629.JPG

      Bereit für den Zusammenbau (linke Bild leider etwas fehlerhaft fokussiert)
      DSC_0645_komprimiert.JPG
      DSC_0646_komprimiert.JPG

      Lüfter und Power Taster (Orange/Weißes Kabel) sind jedoch nur provisorisch verlegt, der Rest sollte so in etwa bleiben.

      Nun, einem Test stand natürlich nichts mehr im Wege. Also Netzstecker rein, Schalter ein und mal schauen ob es qualmt. Kein Zuff, kein nichts, alles supi :P Also mal anschalten. Und läuft! Naja, viel zu sehen ist nicht, da weder onboard noch ext. Graka vorhanden war, aber der BIOS beeper hats mir dann verraten. Zumindest fast. Er piepste 5x lang. Wobei, das fand ich auch erst heraus, nachdem ich beabsichtigt ein Fehler gemacht habe, um zu erkennen, was als lang und als kurzer Beep zu definieren ist.
      Das Problem war mir bei dem Mainboard bekannt, und hatte ich auch schon öfters, als es in meinem PC noch eingebaut war. Jedoch kam es nur teilweise, und hab nie danach geschaut. Nun schien jedoch gar nichts zu gehen. Nach den Beep Codes her ist die CPU defekt. Allerdings konnte ich das testen mit der alten CPU, die jedoch ebenfalls nicht lief mit dem gleichen Resultat. Und das ich gleich zwei CPUs geschrottet hab, konnte ich mir nicht vorstellen. Also die CPU am PC meines Vaters getestet, und die lief! Also ist das Mainboard defekt, was auch immer.
      Da ich das ganze nun jetzt nicht in den Sand setzen möchte, soll ein "neues" Mainboard her. Bei Ebay hab ich nun ein gebrauchtes ersteigert.

      Schade drum :(

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von PewX ()

    • Panther schrieb:

      Habe das selbe Board 970 extreme 3.
      Bei mir setzt irgendwie die CPU einfach aus.
      Und ab und zu die Festplatte für 30 sekunden.
      Habe schon beides gewechselt aber ist immernoch.
      Na wenn alles was aussetzt ausgetauscht wurde, hat vllt ja das, wo es angeschlossen ist ne Macke.
      Aber Aussetzer werden gerne mal auch durch PEAKS im Netzteil verursacht. (Das Board kann das manchmal nicht kompensieren) <-- Aber das nur in ULTRA seltenen fällen. Weiß ich auch nur aus nem Vortrag damals beim Studium, in der Praxis ist mir das noch nicht unter die Augen gekommen.
      [Blockierte Grafik: https://media.giphy.com/media/3oKIP6ZL6nnykKFuLe/giphy.gif]
      Post's never die :D
    • Ich weiß, alter Thread und so, aber ab und zu werde ich danach gefragt was mich selbst immer wieder wundert.

      Kurz gesagt, ja, das Projekt ist fertig. Auch wenn ich heute den Server nicht mehr Nutze, war es dennoch eine kleine Herausforderung und es hatte großen Spaß gemacht. Manchmal ist halt einfach nur der Weg das Ziel ;)
      ABER, ich plane aktuell ein neues Projekt, was ich bei Interesse gerne teilen kann. Der eigene Aufbau eines NAS Systems (Netzwerkspeicher) :)

      Möchte aber dennoch kurz ausholen, warum ich den Schubladenserver heute nicht mehr nutze.
      Den Server nutzte ich wie damals geplant als Entwicklungs- sowie Testserver. Das ging das ganze Jahr 2016 recht gut. Irgendwann fing er jedoch an, einfach so abzustürzen. War ewig auf der Fehlersuche und bin zum Entschluss gekommen, dass entweder die Festplatte oder das Mainboard Fehlerbehaftet ist. Trotz Abstürze habe ich ihn dann doch noch recht lange genutzt. Irgendwann hat es mich aber genervt und ich wollte kein Geld mehr investieren.

      Gründe dafür sind Naheliegend:
      - Hoher Stromverbrauch selbst im IDLE Modus (150W)
      - Heizt mein Arbeitszimmer besser auf als mein Desktop PC (im Sommer ziemlich unangenehm)
      - Die Lüfter sind sehr laut, vor allem wenn der CPU Lüfter hoch dreht

      Ja, damit habe ich damals gerechnet, war mir aber egal.

      Im Mai 2017 habe ich mir den HP Elite Slice in der kleinsten Ausstattung gekauft. Der hatte irgendwas zwischen 400€ und 500€ gekostet. Wirklich ein super Teil, der i3 ist flot genug, hat nur 4W im IDLE Betrieb (mit laufendem MySQL, MTA und Webserver), im normalen Betrieb komplett lautlos trotz zwei Lüfter (billige 32GB SSD habe ich selbst nachgerüstet) und von Hitze keine Spur. Dabei ist er schön klein und sieht schön aus auf dem Schreibtisch.

      Vielleicht verkaufe ich irgendwann den Schubladen Serer so wie er ist. Wenn ich ihn allerdings mit Schublade verkaufen will, brauch ich erst einen neuen Schreibtisch :D

      NeonCubix schrieb:

      Ist das Projekt noch Aktuell / Fertig?
      Auch wenn etwas spät, hier ist die Antwort :D