Los Angeles Reallife Installation

  • Other

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Im Zuge eines Serverupgrades ist der Teamspeak-Server derzeit nicht dauerhaft erreichbar.
Wir bitten um Verständnis. Vielen Dank.

  • Los Angeles Reallife Installation

    Guten Tag,

    ich finde das Los Angeles Reallife Script (siehe hier) sehr interessant. Allerdings habe ich derzeit noch einige Probleme bei der Installation, denn ich bekomme es nicht zum laufen. Sobald ich den Server betrete habe ich einen schwarzen Screen vor mir, lediglich im Chat stehen zwei Zeilen, in denen angegeben ist, wie man bestimmte Shader aktiviert/deaktiviert. Vom eigentlichen Script gibt's dort nichts zu sehen.

    Ich vermute, dass ich die ganzen Ordner falsch eingefügt habe und dadurch die Resourcen nicht gefunden werden. Daher wäre es nett, wenn man mir eben kurz und bündig sagen könnte, wie ich bei der Installation vorzugehen habe. Wo müssen die Ordner platziert werden? Sollen die beigelegten Dateien mit den auf dem Server vorhandenen Dateien getauscht werden?

    Besten Dank!

    P.S.: Datenbankverbindung steht, MySQL-Modul (mtamysql.so, Nitrado) ist vorhanden!
  • Hochladen: [LosAngeles]/LosAngeles/ sind die Ordner und so


    Folgende Dateien müssen angepasst werden:


    mysql/mysql_start.lua (Datenbankdaten)
    handy/scripts/server.lua (Datenbankdaten)
    events/christmas/adventskalender_server.lua (Datenbankdaten)
    admin/ticket_server.lua (Datenbankdaten)
    settings/both_Settings.lua (Server-IP, TS-IP & Forum-URL)
    script.lua (Game-Type & Map-Name)



    Dann halt ACL rechte und in MTAServer.conf fürs Auto Start eintragen.
  • Wenn ich das Script downloade haben sieht die Ordner-Struktur so aus:

    la_reallife -> la_reallife -> die ganzen Vio-Dateien, etc.
    Resourcen -> einige Resourcen, wie heligrab, etc.
    notusedscripts -> nicht verwendete Scripts (Detektiv-Arbeit... :3)
    ACL
    MTAServer.conf
    Datenbank

    So, und wo genau müssen diese nun hin? Soll ich also eine Oberkategorie [la_reallife] erstellen und alles unverändert dort reinpacken, oder wie? Und soll ich die ACL und die MTAServer.conf vom LA-Script durch die beim neuen Server vorhandenen ersetzen?

    /E: Ein Noob wie ich braucht ganz klare Anweisungen :) Und keine Angst, ich will keinen Public-Server aufmachen. Nur für mich und ein paar Kumpels zum testen und experimentieren.
  • Genau du erstellst ein Ordner in [] was da stet ist egal du kannst auch das la_reallife das erste in Klammern schmeißen geht auch.

    Nein. Da die Sachen sich gerne mal Unterscheiden. Am besten nur die wichtigesten sachen in der mtaserver.conf eintragen ganz unten was auch starten soll
    Und halt die Module da eintragen.

    In da ACL muss nur der la_reallife und du eingetrage werden sonst nix
  • Funktioniert nicht, beim connecten bleibt der Bildschirm komplett schwarz (bis auf die MTA-Nachricht "connected... Bla Bla").

    Das sagt die Konsole:
    [21:04:09] Compacting accounts database 'internal.db' ...
    [21:04:11] ERROR: Couldn't find file la_gui/cursor.png for resource la_reallife
    [21:04:11] Loading of resource 'la_reallife' failed
    [21:04:11] Resources: 197 loaded, 0 failed
    [21:04:11] Compacting database 'registry.db' ...
    [21:04:11] MODULE: Loaded "MySQL 5.0 database module" (0.50) by "Alberto Alonso <[email protected]>"
    [21:04:11] Starting resources.......
    [21:04:11] ERROR: Couldn't find resource heligrab. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_car. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_water. Check it exists.
    [21:04:11] ERROR: Couldn't find resource watercolor. Check it exists.
    [21:04:11] Server minclientversion is now 1.5.5-9.12356.0
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource policelights. Check it exists.
    [21:04:11] ERROR: Couldn't find resource particle_objects. Check it exists.
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource la_reallife. Check it exists.
    [21:04:11] Querying MTA master server... success! (Auto detected IP:128.####)
    [21:04:11] Authorized serial account protection is enabled for the ACL group(s): `Admin` See mtasa.com/authserial
    [21:04:11] Server started and is ready to accept connections!
    [21:04:11] To stop the server, type 'shutdown' or press Ctrl-C
    [21:04:11] Type 'help' for a list of commands.

    So sieht die Ordner-Struktur aus:
    i.imgur.com/SU4DlST.jpg
  • Hugogo schrieb:

    Funktioniert nicht, beim connecten bleibt der Bildschirm komplett schwarz (bis auf die MTA-Nachricht "connected... Bla Bla").

    Das sagt die Konsole:
    [21:04:09] Compacting accounts database 'internal.db' ...
    [21:04:11] ERROR: Couldn't find file la_gui/cursor.png for resource la_reallife
    [21:04:11] Loading of resource 'la_reallife' failed
    [21:04:11] Resources: 197 loaded, 0 failed
    [21:04:11] Compacting database 'registry.db' ...
    [21:04:11] MODULE: Loaded "MySQL 5.0 database module" (0.50) by "Alberto Alonso <[email protected]>"
    [21:04:11] Starting resources.......
    [21:04:11] ERROR: Couldn't find resource heligrab. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_car. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_water. Check it exists.
    [21:04:11] ERROR: Couldn't find resource watercolor. Check it exists.
    [21:04:11] Server minclientversion is now 1.5.5-9.12356.0
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource policelights. Check it exists.
    [21:04:11] ERROR: Couldn't find resource particle_objects. Check it exists.
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource la_reallife. Check it exists.
    [21:04:11] Querying MTA master server... success! (Auto detected IP:128.####)
    [21:04:11] Authorized serial account protection is enabled for the ACL group(s): `Admin` See mtasa.com/authserial
    [21:04:11] Server started and is ready to accept connections!
    [21:04:11] To stop the server, type 'shutdown' or press Ctrl-C
    [21:04:11] Type 'help' for a list of commands.

    So sieht die Ordner-Struktur aus:
    i.imgur.com/SU4DlST.jpg
    [21:04:11] ERROR: Couldn't find file la_gui/cursor.png for resource la_reallife
    [21:04:11] ERROR: Couldn't find resource heligrab. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_car. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_water. Check it exists.
    [21:04:11] ERROR: Couldn't find resource watercolor. Check it exists.
    [21:04:11] Server minclientversion is now 1.5.5-9.12356.0
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource policelights. Check it exists.
    [21:04:11] ERROR: Couldn't find resource particle_objects. Check it exists.
    [21:04:11] ERROR: Couldn't find resource snow. Check it exists.
    [21:04:11] ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    [21:04:11] ERROR: Couldn't find resource la_reallife. Check it exists.

    beim dir fehle die datei...

    ..versucht einfach den google übersetz zu nutzen ^^
  • Hugogo schrieb:

    ERROR: Couldn't find file la_gui/cursor.png for resource la_reallife
    Die Datei musst du Überprüfen ob sie da ist wenn sie da ist ob das png groß oder klein geschrieben ist

    Hugogo schrieb:

    ERROR: Couldn't find resource heligrab. Check it exists.
    ERROR: Couldn't find resource shader_car. Check it exists.
    ERROR: Couldn't find resource shader_water. Check it exists.
    ERROR: Couldn't find resource watercolor. Check it exists.
    ERROR: Couldn't find resource snow. Check it exists.

    ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    ERROR: Couldn't find resource policelights. Check it exists.
    ERROR: Couldn't find resource particle_objects. Check it exists.
    ERROR: Couldn't find resource snow. Check it exists.
    ERROR: Couldn't find resource shader_snow_ground. Check it exists.
    ERROR: Couldn't find resource la_reallife. Check it exists.
    Das kann daran liegen das er sie nicht findet, Mach mal die Sachen im Resourcen Ordner in den Originalen Resourcen Ordner
  • Hugogo schrieb:

    Bonus schrieb:

    Zeig mal auch die Ordnerstruktur in la_reallife.
    Falls es wegen den Resourcen ist, die er nicht findet -> Die befinden sich im Ordner "Resourcen" (siehe Screen weiter oben)
    Auf dem Screen sieht man die Struktur vom Ordner la_reallife nicht.

    Du meintest vorher:
    "la_reallife -> la_reallife -> die ganzen Vio-Dateien, etc."
    Welches dieser la_reallife Ordner hast du reingepackt?
    Denn die Ressource kann nur gefunden werden, wenn die meta.xml Datei DIREKT im Ordner ohne eckige Klammern ist.

    Wenn es also bei dir so aussieht:
    resources -> [la_reallife] -> la_reallife -> la_reallife -> meta.xml
    Dann ist die meta.xml nicht DIREKT im ersten Ordner ohne eckige Klammern, weshalb der Ordner dann nicht als Ressource erkannt werden kann.
    Ändere es so ab:
    resources -> [la_reallife] -> la_reallife -> meta.xml (und Rest eben)
    Also einfach so, dass der Ordner la_reallife mit der meta.xml drin entweder direkt in resources drin ist oder in einem Ordner mit eckigen Klammern (wie [la_reallife]).


    Und wegen den anderen Ressourcen das selbe tun - nenn den Ordner "Ressourcen" um in "[Ressourcen]" oder pack die einzelnen Ressourcen direkt in den "resources" Ordner.
    Mein Discord:
    discord.gg/Kpm3CYB

    Nächstes Projekt auf nan0s-w0rld

    Miitglied der denismit1n Gruppe mit 6 Ehre
  • Eine Ressource ist ein Ordner ohne eckigen Klammern im resources-Ordner mit einer ordentlichen meta.xml.
    Die Ressource darf in anderen Ordnern sein, solange die Namen aller Ordner, wo die Ressource drin ist, mit einem "[" anfangen und mit einem "]" aufhören.

    Bei dir jedoch wäre die Ressource "[la_reallife]", da hier drin die meta.xml ist.
    Aber das ist nicht erlaubt, weil der Name des Ordners der Ressource selbst nicht in eckigen Klammern sein darf.
    Also "[la_reallife]" in "la_reallife" umbenennen oder einen Ordner namens "la_reallife" in "[la_reallife]" reinpacken und da alle Dateien reinpacken (meta.xml usw.).
    Mein Discord:
    discord.gg/Kpm3CYB

    Nächstes Projekt auf nan0s-w0rld

    Miitglied der denismit1n Gruppe mit 6 Ehre